User Guide : Importing Prior Version Projects and Artifacts : Importing Version 9 Workspace
 
Share this page             
Importing Version 9 Workspace
Importing version 9 repositories does not move the folders and files. The version 11 projects point to the location of your v9 physical file locations. Since changing some of these files in version 11 will make them incompatible with the version 9 UI and engine, it is recommended that you do one of the following before importing the workspace to version 11:
Backup your version 9 workspace.
Copy your version 9 workspace and import the copy instead of the original workspace.
Note:  Version 9 workspaces contain a file called Repositories.xml. This file contains entries for version 9 artifact locations. If your version 9 workspace does not contain a Repositories.xml file, see Importing Artifacts from Folder.
To import a version 9 workspace
1. Launch DataConnect Studio IDE.
2. Make sure you have a valid version 11 license. For more information, see Uploading License File.
3. Go to File > Import or right-click in Project Explorer and select Import.
The Import window is displayed.
4. Expand DataConnect, click From v9 Data Integrator Workspace, and click Next.
The From v9 Data Integrator Workspace window is displayed.
5. In v9 workspace, click Browse and specify a version 9 workspace that contains a Repositories.xml file.
A list of repositories is displayed.
Note:  Repositories will become projects in version 11.
6. Select the repositories that you want to import.
7. Optionally, you can specify the following:
Copy v9 repository files to workspace (recommended) - Select this option to import a copy of the v9 repository files to the current workspace. If you do not select this option, then the import works similar to importing From Folder. After the artifacts are imported, they may no longer be backward compatible with previous versions.
Copy and Set DataConnect macro definition file preference - Select this option if a macrodef.xml file is available in the same location as the repositories.xml file. The macrodef.xml file will be copied into the workspace and the macro definition preference in Options > Manage Macros will be set to the macrodef.xml file.
Set DataConnect user defined connections location preference - Select this option if the location of the repositories.xml contains a connections folder. If this folder is available then, the Options > Preferences > DataConnect > General > User Defined Connections Location will be set to the connections folder location so that v9 user-defined connections can be loaded into v11.
Convert Relative Paths to Absolute - v9 allowed for dependent artifacts to have relative paths. Select this option to convert the file path of the dependent artifacts from relative path locations to absolute path locations.
8. Click Finish.
The Import Complete window is displayed that provides information about the log file location for the import, and the files that are not imported due to errors. You can click View Log to open the log file and view the import details. Also, the repositories are imported as projects in Project Explorer.
During import, the following occurs:
Each selected repository is imported as a new project. The project name is the earlier v9 repository name.
The location of the projects and artifacts depends on the copy option. The copy operation can take a long time if the repositories are large.
A .project file is created in the workspace/project location. This makes the folder an official DataConnect project.
The .metadata/.plugins/or.eclipse.core.resources/.projects workspace folder is updated to contain the project name folder that contains the metadata about the project including its location.
All the artifact dependency paths and file names are checked and edited as appropriate.
A DataConnect_copy_{date-time}.log is generated. You can review this log to view any modification, the files that you were not able to locate, and so on. Any problematic files may need to be manually edited.